# CVE-2026-77406: RabbitMQ amqp091-go: Consumer Message Flooding via Signed-to-Unsigned Integer Casting in Qos Configuration

> An attacker with control over Qos configuration can cause memory exhaustion and denial of service in applications using the RabbitMQ Go client.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** AZL-103188, AZL-103287, CLEANSTART-2026-KU86839, CLEANSTART-2026-QW84493, CLEANSTART-2026-VO07042, DEBIAN-CVE-2026-77406, ECHO-0cd4-3c49-5d6c, GHSA-rm6m-hrcw-jw33, GO-2026-6502, MINI-222w-m367-74w8, MINI-22gf-66xp-2hm2, MINI-29pp-xf75-8mcf, MINI-2gq5-x492-x8wp, MINI-2hw2-622x-2h9h, MINI-2m64-rhr4-9rmx, MINI-3jg9-g22v-x83c, MINI-44xh-f664-ccq3, MINI-4g94-crjg-qpcv, MINI-5pmv-cjq9-5phc, MINI-6v82-4g8m-m2xv, MINI-7c7f-3q2r-hvvj, MINI-7gfc-2p55-cp98, MINI-7v55-m5fc-qvqg, MINI-8pw7-c4c6-rcc2, MINI-c456-8jq2-wqqh, MINI-cm7f-mc4w-6w39, MINI-cx7w-33hw-53ch, MINI-fmpj-v7mr-8wgr, MINI-gc9m-3r94-gwrm, MINI-ghr4-4v94-vcx4, MINI-hv96-9f9p-c6rh, MINI-jjjp-86w3-2mrj, MINI-m3m7-4xf3-9m6h, MINI-m89f-ww7v-8vfc, MINI-q328-fvjx-5h7p, MINI-q3w4-92w7-29fm, MINI-q84f-f9fx-qwmm, MINI-qr5v-632m-796q, MINI-r3m2-pxh7-7785, MINI-r7mv-vvph-487f, MINI-rqmp-v8pv-945j, MINI-v838-hprf-988h, MINI-v83p-q29r-h34w, MINI-wj72-hh9j-2vrm, MINI-ww5q-c54f-phv6, ROOT-APP-GOBINARY-CVE-2026-77406, UBUNTU-CVE-2026-77406

## What is CVE-2026-77406?

CVE-2026-77406 is a high-severity vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, Channel.Qos in channel.go accepts negative prefetchCount and prefetchSize integers and casts them directly to uint16 and uint32 fields in the basic.qos method because validateQos is absent. Values such as -1 therefore wrap to 65535 or 4294967295 instead of being rejected. An application that permits untrusted configuration of these Qos values can unintentionally request extremely large prefetch limits, allowing a broker to deliver enough queued messages to exhaust client memory and disrupt processing. This issue is fixed in version 1.13.0.

Weakness: CWE-195 (Signed to Unsigned Conversion Error)

## Which versions are affected by CVE-2026-77406?

3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-77406?

Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.

## Is CVE-2026-77406 being exploited?

There is no known exploitation of CVE-2026-77406 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77406 and fix it if it is affected.

What it is: CVE-2026-77406 is a high-severity vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77406 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77406/ (Markdown: https://insights.sbomify.com/CVE-2026-77406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77406
- OSV: https://osv.dev/vulnerability/CVE-2026-77406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77406/
Summaries are generated and may contain mistakes; the official description above is the record.
