# CVE-2026-77407: RabbitMQ amqp091-go: Plaintext Credential Exposure via Exported PLAIN Authentication Struct Fields

> Attackers with access to application memory or logs can extract RabbitMQ credentials because the Go client library fails to clear plaintext passwords after authentication.

- **Severity:** High 7.0 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** AZL-103194, AZL-103278, CLEANSTART-2026-CK95490, CLEANSTART-2026-JZ39713, CLEANSTART-2026-LD19484, DEBIAN-CVE-2026-77407, ECHO-1f45-9931-8879, GHSA-27gv-rfvv-22mv, GO-2026-6491, MINI-259x-mm89-xhpj, MINI-262g-fx6j-vqm7, MINI-2grh-hr7x-cg75, MINI-2vrw-vwmf-8cq3, MINI-3m7x-q8j6-2wpw, MINI-3xxh-8ccq-3x3p, MINI-44xx-xv93-8gh8, MINI-5xr8-6mw6-wjw3, MINI-65jj-v4mh-8h35, MINI-6xc5-q7px-5jqq, MINI-89mw-c842-v28g, MINI-8fv7-4p52-c6gq, MINI-9979-c8cr-rrcw, MINI-9ph2-fj7v-878h, MINI-c7wx-whvx-wg3h, MINI-f6fw-44rh-9w2c, MINI-fc7q-5qq9-7mg8, MINI-ffvv-qhpm-cq6r, MINI-fq7h-fqhf-hqrx, MINI-g8f8-f55r-84pp, MINI-ggj4-ccw2-p4c9, MINI-h84w-6j9x-7j6w, MINI-hgv9-ccw7-h59j, MINI-j5hq-w7gc-jc79, MINI-jg2p-2xr6-74ww, MINI-jp92-3585-5xq5, MINI-mp2g-h46f-65mc, MINI-phg4-633c-22g3, MINI-pm76-q8pc-cmqr, MINI-pvp2-v9h6-wwc8, MINI-rjf7-x2g3-7gh5, MINI-wfc3-r2p9-4j8j, MINI-wm97-58r8-2jqf, MINI-wpmg-79fj-2pvp, MINI-wv8x-g4mj-m4v5, MINI-xwh7-ww76-59cw, ROOT-APP-GOBINARY-CVE-2026-77407, UBUNTU-CVE-2026-77407

## What is CVE-2026-77407?

CVE-2026-77407 is a high-severity vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, PlainAuth values defined in auth.go retain passwords as exported plaintext fields in Connection.Config.SASL after a successful PLAIN authentication handshake. The Connection.openComplete method in connection.go does not clear those values. Code with access to the Connection object, including reflective loggers, application performance monitoring agents, debugging utilities, and panic handlers, can traverse the configuration and expose the credentials to logs or state captures. The credential remains available for the lifetime of the connection instead of being cleared after authentication. This issue is fixed in version 1.13.0.

Weakness: CWE-316 (Cleartext Storage of Sensitive Information in Memory)

## Which versions are affected by CVE-2026-77407?

3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-77407?

Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.

## Is CVE-2026-77407 being exploited?

There is no known exploitation of CVE-2026-77407 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77407 and fix it if it is affected.

What it is: CVE-2026-77407 is a high-severity vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77407 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77407/ (Markdown: https://insights.sbomify.com/CVE-2026-77407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77407
- OSV: https://osv.dev/vulnerability/CVE-2026-77407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77407/
Summaries are generated and may contain mistakes; the official description above is the record.
