# CVE-2026-77408: RabbitMQ amqp091-go: Silent Data Truncation and State Corruption via Shortstr Integer Overflow

> An integer overflow in the Go AMQP client library causes silent data truncation of message properties, leading to state corruption and broken message processing.

- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** AZL-103212, AZL-103275, CLEANSTART-2026-KV65948, CLEANSTART-2026-ND68008, CLEANSTART-2026-TI12520, DEBIAN-CVE-2026-77408, ECHO-b9a5-5edf-f6d5, GHSA-j497-x9hr-x34x, GO-2026-6498, MINI-2jh6-2rj3-p4fj, MINI-3gx7-mvp4-cx2h, MINI-3w8j-4jvr-2hq2, MINI-55xw-7gw7-3mj8, MINI-64q5-7hv2-76j8, MINI-6668-x24g-pc34, MINI-66p5-3679-487f, MINI-6qm3-26pg-xqq6, MINI-6rq4-v274-cmcg, MINI-73px-h3p7-f953, MINI-7x52-qpvc-p54p, MINI-979q-296c-8p4p, MINI-c8r5-hrhp-2x8j, MINI-crrc-36vj-cfgc, MINI-f72r-g44x-7j9g, MINI-f7j4-mjwm-m6p9, MINI-fv2j-pjqm-jwr7, MINI-g86q-jv8c-xxfm, MINI-ghg5-4rfh-f3w7, MINI-h2m7-q573-pxcc, MINI-h6q5-hhfc-98mj, MINI-hw92-mjvc-4r6f, MINI-j4j8-h4jx-5jv2, MINI-j5hp-6cwg-mv8v, MINI-mrh2-m5x4-5926, MINI-r4p4-f8h9-7p9j, MINI-rjxj-57h3-5pgh, MINI-rw26-qq9j-rf2m, MINI-vc7w-rmpm-7jq6, MINI-vfph-vf2g-7jj6, MINI-vrj5-qq2c-g88r, MINI-wgjv-vcq6-hr9h, MINI-wmr4-qrrg-f3gc, MINI-x6x3-3f2v-wh8h, MINI-xq6p-r32q-rr2g, MINI-xv82-rwrm-j85m, ROOT-APP-GOBINARY-CVE-2026-77408, UBUNTU-CVE-2026-77408

## What is CVE-2026-77408?

CVE-2026-77408 is a critical vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, the writeShortstr function in write.go casts the byte length of AMQP shortstr property values to uint8 without first rejecting values longer than 255 bytes. An application that accepts an oversized CorrelationId, ReplyTo, MessageId, Expiration, UserId, AppId, ContentType, ContentEncoding, or Type value can therefore serialize a wrapped length and only a truncated prefix, while reporting no error. The resulting silent metadata corruption can break request and reply correlation, routing, tracing, and downstream message processing. This issue is fixed in version 1.13.0.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-77408?

3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-77408?

Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.

## Is CVE-2026-77408 being exploited?

There is no known exploitation of CVE-2026-77408 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77408 and fix it if it is affected.

What it is: CVE-2026-77408 is a critical vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77408 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77408/ (Markdown: https://insights.sbomify.com/CVE-2026-77408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77408
- OSV: https://osv.dev/vulnerability/CVE-2026-77408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77408/
Summaries are generated and may contain mistakes; the official description above is the record.
