# CVE-2026-77409: RabbitMQ amqp091-go: Denial of Service via Synchronous Event Channel Blocking

> An attacker can cause denial of service in RabbitMQ Go clients by triggering event bursts that block the reader goroutine if channels are unbuffered or full.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** AZL-103197, AZL-103281, DEBIAN-CVE-2026-77409, GHSA-wxx3-cj7g-w73j, UBUNTU-CVE-2026-77409

## What is CVE-2026-77409?

CVE-2026-77409 is a high-severity denial of service vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, Channel.dispatch in channel.go, confirms.confirm in confirms.go, and Connection.dispatch0 in connection.go synchronously send publisher confirmations, flow-control events, consumer cancellations, returned messages, including NotifyConfirm events and connection block notifications, to application-provided channels. If a listener channel is unbuffered, full, or not drained promptly, the sole reader goroutine blocks and stops processing frames, acknowledgments, deliveries, and heartbeats. Broker-driven event bursts can therefore cause connection stalls, missed heartbeats, deadlocks, and disconnection. This issue is fixed in version 1.13.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-77409?


## How do I fix CVE-2026-77409?

Upgrade to a fixed version.

## Is CVE-2026-77409 being exploited?

There is no known exploitation of CVE-2026-77409 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77409 and fix it if it is affected.

What it is: CVE-2026-77409 is a high-severity denial of service vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77409 in the wild and no public exploit code.

Affected product: rabbitmq amqp091-go. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77409/ (Markdown: https://insights.sbomify.com/CVE-2026-77409/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77409
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77409
- OSV: https://osv.dev/vulnerability/CVE-2026-77409

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77409/
Summaries are generated and may contain mistakes; the official description above is the record.
