# CVE-2026-77411: RabbitMQ amqp091-go: Protocol Desynchronization and Frame Injection via Integer Overflow in readLongstr

> A malicious AMQP broker can cause protocol desynchronization and disrupt connection integrity in the amqp091-go library via an integer overflow in readLongstr.

- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** AZL-103206, AZL-103290, CLEANSTART-2026-DE21669, CLEANSTART-2026-VZ69242, CLEANSTART-2026-WU83692, DEBIAN-CVE-2026-77411, ECHO-b49e-b716-88c1, GHSA-c5pq-fr2g-9jpf, GO-2026-6496, MINI-225c-vm69-pv6j, MINI-2ghq-pc5p-q89m, MINI-3572-6qv4-5cgq, MINI-3hjf-v6m3-q6c6, MINI-4pxc-m64x-wmvw, MINI-53pm-2hv4-grc7, MINI-589v-r767-pcqg, MINI-58r7-r73v-48wh, MINI-625f-q6m5-gfrg, MINI-628j-23hx-rg8x, MINI-79rr-q7vp-v8hc, MINI-7m64-9w64-ff82, MINI-7v78-c8c6-xqg9, MINI-8qpr-cvwx-cpgw, MINI-9gcw-5jqf-263c, MINI-9mwm-hfh8-5338, MINI-9r79-fc9w-h2qj, MINI-c4rm-xq2c-322v, MINI-cjv2-8j5m-3796, MINI-cx7g-39xj-f76c, MINI-g3vj-9j69-rjwx, MINI-h5qv-ffg2-p947, MINI-hrqw-fw2h-hw25, MINI-hv69-x874-r8p3, MINI-jcx8-pmhx-45w8, MINI-jv6x-m886-x33p, MINI-jx35-56r9-5xxx, MINI-q4c5-wh27-f945, MINI-q69m-mqhp-4f66, MINI-qh4m-q986-j6xg, MINI-r57v-h65x-qxj5, MINI-v628-7vwg-p4vx, MINI-vgfc-42jc-99mw, MINI-vm33-j42p-h4x6, MINI-xpq8-xhp2-279f, MINI-xw49-j6w2-mx6p, ROOT-APP-GOBINARY-CVE-2026-77411, UBUNTU-CVE-2026-77411

## What is CVE-2026-77411?

CVE-2026-77411 is a critical vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, readLongstr in read.go returns an empty string and a nil error when a declared AMQP longstr length exceeds 0x7FFFFFFF instead of returning ErrSyntax. The function leaves the declared field bytes unread, while readTable treats the operation as successful and continues parsing from the wrong offset. A malicious or compromised broker can provide an oversized longstr in a table field and desynchronize subsequent AMQP parsing, causing attacker-controlled trailing bytes to be interpreted as later fields or frames and disrupting connection integrity and availability. This issue is fixed in version 1.13.0.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-77411?

3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-77411?

Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.

## Is CVE-2026-77411 being exploited?

There is no known exploitation of CVE-2026-77411 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77411 and fix it if it is affected.

What it is: CVE-2026-77411 is a critical vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77411 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77411/ (Markdown: https://insights.sbomify.com/CVE-2026-77411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77411
- OSV: https://osv.dev/vulnerability/CVE-2026-77411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77411/
Summaries are generated and may contain mistakes; the official description above is the record.
