# CVE-2026-77412: RabbitMQ amqp091-go: Denial of Service via Malicious Field Length in AMQP Client

> A malicious AMQP broker can cause a client panic and process termination by sending a crafted field length, requiring an upgrade to the Go client library.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** AZL-103203, AZL-103293, CLEANSTART-2026-FS32533, CLEANSTART-2026-JY06223, CLEANSTART-2026-PK85962, DEBIAN-CVE-2026-77412, ECHO-3d51-73a3-7456, GHSA-4v58-74mf-rjx3, GO-2026-6494, MINI-27r4-65pv-8pgm, MINI-2g4g-97r2-8mfh, MINI-2r75-jwh2-wpjh, MINI-3356-p2g7-vxh9, MINI-362c-92cg-c8f7, MINI-3f6p-mm2c-c8c7, MINI-3mjr-5qg9-pq6c, MINI-3rx8-w45x-mr4w, MINI-49mw-hhw4-9xvq, MINI-4gwp-gg3j-2r2v, MINI-4pvx-pjjj-gq52, MINI-5h99-745p-6985, MINI-5j8g-q4gq-g8h7, MINI-5pv3-9jwm-x2x4, MINI-68h7-6jcw-6w86, MINI-6hjj-jghw-jw2h, MINI-7qh4-p2fw-3j2f, MINI-9r4w-6fx3-472m, MINI-9v6f-p64w-37pj, MINI-g9j6-rfw5-9prw, MINI-gcgw-45mj-34hj, MINI-hjf3-jfqh-259v, MINI-hmjj-pcrf-h4f9, MINI-jvh7-xq4v-6j89, MINI-mf87-x3g3-qw2p, MINI-mjxj-qxrv-xfvr, MINI-qf8c-7wgc-jqvx, MINI-r467-rc32-hr5j, MINI-rqq7-p8jh-wh48, MINI-rvfg-hf9x-r42r, MINI-v7qj-6r2w-cg38, MINI-v852-jr5j-xqrj, MINI-vpwh-jrjv-prw5, MINI-w6pj-hffh-wfx4, MINI-xm6m-g7v5-5c7f, MINI-xq55-4h8c-5g7r, ROOT-APP-GOBINARY-CVE-2026-77412, UBUNTU-CVE-2026-77412

## What is CVE-2026-77412?

CVE-2026-77412 is a high-severity denial of service vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, readField in read.go reads the length of an AMQP byte-array field with type tag x into a signed int32 and passes the value directly to make when allocating the field buffer. A malicious or compromised broker can encode a value such as 0xFFFFFFFF, which becomes -1 and causes a len out of range runtime panic. The panic escapes the network reader goroutine and terminates the client process, including during connection.start server properties or message header table parsing. This issue is fixed in version 1.13.0.

Weakness: CWE-681 (Incorrect Conversion between Numeric Types)

## Which versions are affected by CVE-2026-77412?

3 open source packages ship an affected version, including github.com/rabbitmq/amqp091-go.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |
| `github.com/rabbitmq/amqp091-go` | Go | All versions | 1.13.0 |

## How do I fix CVE-2026-77412?

Upgrade github.com/rabbitmq/amqp091-go to 1.13.0 or later.

## Is CVE-2026-77412 being exploited?

There is no known exploitation of CVE-2026-77412 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77412 and fix it if it is affected.

What it is: CVE-2026-77412 is a high-severity denial of service vulnerability in rabbitmq amqp091-go, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77412 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0
- github.com/rabbitmq/amqp091-go (Go): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77412/ (Markdown: https://insights.sbomify.com/CVE-2026-77412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77412
- OSV: https://osv.dev/vulnerability/CVE-2026-77412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77412/
Summaries are generated and may contain mistakes; the official description above is the record.
