# CVE-2026-77414: JSONata: Arbitrary Code Execution via crafted JSONata expressions

> Attackers can execute arbitrary code by crafting malicious JSONata expressions that bypass security checks to access Node.js process modules.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** CLEANSTART-2026-JA64028, GHSA-2943-5xfg-gq5f, MINI-28hp-r8cp-hcc3, MINI-3q88-gmw8-6g3f, MINI-m8x9-c7m2-h683

## What is CVE-2026-77414?

CVE-2026-77414 is a critical code injection vulnerability in jsonata-js jsonata, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JSONata is a JSON query and transformation language. Prior to 1.8.8 and 2.2.1, the src/jsonata.js environment.lookup function used a bypassable hasOwnProperty check. Crafted expressions could use $hasOwnProperty, $spread, $string, prototype access, and $constructor to reach the object prototype and invoke process.getBuiltinModule with child_process, executing arbitrary code with the privileges of the host process. This issue is fixed in versions 1.8.8 and 2.2.1.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-77414?

4 open source packages ship an affected version, including jsonata.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsonata` | npm | All versions | 1.8.8 |
| `jsonata` | npm | All versions | 1.8.8 |
| `jsonata` | npm | From 2.0.0 | 2.2.1 |
| `jsonata` | npm | From 2.0.0 | 2.2.1 |

## How do I fix CVE-2026-77414?

Upgrade jsonata to a fixed version for your release line: 1.8.8 or 2.2.1.

## Is CVE-2026-77414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77414 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77414 and fix it if it is affected.

What it is: CVE-2026-77414 is a critical code injection vulnerability in jsonata-js jsonata, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77414 exists.

Affected packages and fixed versions:
- jsonata (npm): affected all versions; fixed in 1.8.8
- jsonata (npm): affected all versions; fixed in 1.8.8
- jsonata (npm): affected from 2.0.0; fixed in 2.2.1
- jsonata (npm): affected from 2.0.0; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77414/ (Markdown: https://insights.sbomify.com/CVE-2026-77414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77414
- OSV: https://osv.dev/vulnerability/CVE-2026-77414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77414/
Summaries are generated and may contain mistakes; the official description above is the record.
