# CVE-2026-77465: toml-node: Uncontrolled Recursion

> A remote attacker can cause a denial of service by sending a deeply nested TOML document that exhausts the call stack in the toml-node parser.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2026
- **Updated:** 4 Sep 2026
- **Also known as:** CLEANSTART-2026-VM09695, ECHO-1d3f-fb8f-0075, GHSA-82x6-q7mm-w9cf, MINI-45gg-h96p-58gp, ROOT-APP-NPM-CVE-2026-77465

## What is CVE-2026-77465?

CVE-2026-77465 is a high-severity denial of service vulnerability in BinaryMuse toml-node, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

toml-node is a TOML parser for Node.js and the browser. Prior to 4.2.0, toml.parse() uses a Peggy 5.1.0 generated recursive-descent parser in lib/parser.js whose peg$parsevalue, peg$parsearray, and peg$parseinline_table_entry functions recurse through nested arrays and inline tables without a depth limit. A remote unauthenticated application parsing an attacker-controlled TOML document containing a few thousand nested arrays or inline tables can exhaust the Node.js call stack, raise an unexpected RangeError rather than the parser's SyntaxError, and terminate an unprotected request worker or process. The corresponding grammar source is src/toml.pegjs, where the generated parser must be bounded. This issue is fixed in version 4.2.0.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-77465?

2 open source packages ship an affected version, including toml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `toml` | npm | All versions | 4.2.0 |
| `toml` | npm | All versions | 4.2.0 |

## How do I fix CVE-2026-77465?

Upgrade toml to 4.2.0 or later.

## Is CVE-2026-77465 being exploited?

There is no known exploitation of CVE-2026-77465 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77465 and fix it if it is affected.

What it is: CVE-2026-77465 is a high-severity denial of service vulnerability in BinaryMuse toml-node, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77465 in the wild and no public exploit code.

Affected packages and fixed versions:
- toml (npm): affected all versions; fixed in 4.2.0
- toml (npm): affected all versions; fixed in 4.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77465/ (Markdown: https://insights.sbomify.com/CVE-2026-77465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77465
- OSV: https://osv.dev/vulnerability/CVE-2026-77465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77465/
Summaries are generated and may contain mistakes; the official description above is the record.
