# CVE-2026-77467: Lychee: A single 383-byte PDF causes ~184 seconds of CPU consumption in the real processing path

> Authenticated users can cause significant CPU exhaustion and service delays by uploading small PDFs with oversized dimensions, impacting web workers or processing queues.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-6736-fhxv-3p79

## What is CVE-2026-77467?

CVE-2026-77467 is a high-severity denial of service vulnerability in LycheeOrg Lychee, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lychee is a free, open-source photo-management tool. Prior to 7.7.0, Lychee enables ImageMagick PDF support with Ghostscript but does not apply an effective pre-render limit to PDF page dimensions in ImagickHandler::loadPdf(). An authenticated user who can upload a small PDF with an oversized /MediaBox can cause Imagick::readImage() to consume substantial CPU before failing to produce an image. When QUEUE_CONNECTION selects synchronous processing the request can occupy a web worker, while the official asynchronous Docker configuration can clog the shared image-processing queue and delay other work. The advisory did not identify a Ghostscript sandbox escape. This issue is fixed in version 7.7.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-77467?


## How do I fix CVE-2026-77467?

No fix has been published for CVE-2026-77467 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77467 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77467 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77467 and fix it if it is affected.

What it is: CVE-2026-77467 is a high-severity denial of service vulnerability in LycheeOrg Lychee, published on 15 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77467 exists.

Affected product: LycheeOrg Lychee. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77467/ (Markdown: https://insights.sbomify.com/CVE-2026-77467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77467
- OSV: https://osv.dev/vulnerability/CVE-2026-77467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77467/
Summaries are generated and may contain mistakes; the official description above is the record.
