# CVE-2026-77470: Business logic in Lychee

> An attacker can manipulate payment amounts in the webshop checkout to purchase items at a lower price than intended.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** GHSA-476v-jr53-8rxc

## What is CVE-2026-77470?

CVE-2026-77470 is a high-severity vulnerability in LycheeOrg Lychee, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lychee is a free, open-source photo-management tool. Prior to 7.7.1, the Supporter or Pro webshop POST /api/v2/Shop/Checkout/Process flow accepts an unrestricted additional_data array and CheckoutService::preparePurchaseParameters() merges it after server-computed purchase parameters. Because later string keys overwrite earlier keys, an unauthenticated buyer can replace amount, currency, returnUrl, cancelUrl, or transactionId before CheckoutService::processPayment() passes the parameters to a non-PayPal Omnipay gateway. An attacker can therefore make a gateway accept a successful payment for an attacker-selected amount and obtain auto-fulfilled goods while underpaying the merchant. The issue requires an enabled webshop, a purchasable item, and an affected Omnipay gateway. This issue is fixed in version 7.7.1.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-472 (External Control of Assumed-Immutable Web Parameter), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-77470?


## How do I fix CVE-2026-77470?

No fix has been published for CVE-2026-77470 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77470 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77470 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77470 and fix it if it is affected.

What it is: CVE-2026-77470 is a high-severity vulnerability in LycheeOrg Lychee, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77470 exists.

Affected product: LycheeOrg Lychee. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77470/ (Markdown: https://insights.sbomify.com/CVE-2026-77470/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77470
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77470
- OSV: https://osv.dev/vulnerability/CVE-2026-77470

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77470/
Summaries are generated and may contain mistakes; the official description above is the record.
