# CVE-2026-77474: Denial of service in destructive command guard

> Crafted shell commands cause exponential-time processing, hanging the tool and allowing destructive commands to bypass safety guards due to fail-open behavior.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** GHSA-4cfr-w3v5-w5j5

## What is CVE-2026-77474?

CVE-2026-77474 is a high-severity denial of service vulnerability in Dicklesworthstone destructive_command_guard, published on 16 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

destructive_command_guard (dcg) is a command-line safety tool that blocks destructive shell commands before AI coding agents run them. Prior to 0.6.6, nested or unclosed substitutions are recursively rescanned after an inner scan returns unterminated, producing exponential-time work. The affected scanners are reached through split_command_segments in src/packs/mod.rs. a destructive command followed by nested or unclosed $( or $(( sequences. nested or unclosed $( and $(( sequences cause repeated rescanning of the remaining command suffix. a hung PreToolUse hook fails open, allowing the destructive command to proceed. This issue is fixed in version 0.6.6.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-77474?


## How do I fix CVE-2026-77474?

No fix has been published for CVE-2026-77474 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77474 being exploited?

There is no known exploitation of CVE-2026-77474 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77474 and fix it if it is affected.

What it is: CVE-2026-77474 is a high-severity denial of service vulnerability in Dicklesworthstone destructive_command_guard, published on 16 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-77474 in the wild and no public exploit code.

Affected product: Dicklesworthstone destructive_command_guard. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77474/ (Markdown: https://insights.sbomify.com/CVE-2026-77474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77474
- OSV: https://osv.dev/vulnerability/CVE-2026-77474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77474/
Summaries are generated and may contain mistakes; the official description above is the record.
