CVE-2026-77528 Autobahn Python permessage-deflate bypasses maxMessagePayloadSize after inflation

Medium 5.3 Published Updated

Remote attackers can cause resource exhaustion in Autobahn Python by sending compressed WebSocket frames that bypass payload size limits after inflation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-77528?

CVE-2026-77528 is a medium-severity denial of service vulnerability in crossbario autobahn-python, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Autobahn Python is a WebSocket and WAMP implementation for Python that supports Twisted and asyncio. Prior to 26.7.1, WebSocket endpoints that accept permessage-deflate and rely on maxMessagePayloadSize enforce that limit against the compressed frame length before inflation but do not recheck the decompressed message size before delivery. A remote unauthenticated client can send a valid compressed frame below the configured wire-size limit that expands beyond the application message limit, causing oversized data to be allocated, joined, validated, and passed to application callbacks. This can create resource-exhaustion pressure, but the advisory does not establish confidentiality or integrity impact. This issue is fixed in version 26.7.1.

Weakness: CWE-770, CWE-409

Which versions are affected by CVE-2026-77528?

6 open source packages ship an affected version, including autobahn and crossbar.

PackageAffectedFixed in
autobahn PyPIAll versions26.7.1
autobahn PyPIAll versions26.7.1
autobahn PyPIAll versions26.7.1
crossbar PyPIAll versions26.7.1
crossbar PyPIAll versions26.7.1
crossbar PyPIAll versions26.7.1
Linux distribution packages (1)
python-autobahn openSUSE:TumbleweedAll versions26.7.1-2.1

How do I fix CVE-2026-77528?

Upgrade autobahn to 26.7.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-77528 being exploited?

There is no known exploitation of CVE-2026-77528 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-77528, GHSA-hxp9-w8x3-p566, PYSEC-2026-4027, PYSEC-2026-4031, UBUNTU-CVE-2026-77528, openSUSE-SU-2026:11852-1.

Is CVE-2026-77528 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free