# CVE-2026-77601: OpenC3 COSMOS: Authenticated OS command injection via the `pypi_url` setting

> Authenticated attackers can inject OS commands via the pypi_url setting during plugin installation, executing arbitrary code as the service user.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-vp3w-52v9-q57f

## What is CVE-2026-77601?

CVE-2026-77601 is a high-severity command injection vulnerability in OpenC3 cosmos, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. From 5.12.0 until 7.3.0, an authenticated actor can write the pypi_url setting through set_setting at POST /openc3-api/api, then cause OpenC3::PluginModel.install_phase2 in openc3/lib/openc3/models/plugin_model.rb to interpolate the value into a shell command while installing a plugin with Python dependency metadata. Shell metacharacters in the setting are interpreted by the command shell, allowing arbitrary operating-system commands to run as the openc3 service user with access to Redis and bucket credentials. Open-source deployments permit any authenticated user to reach the affected operations, while Enterprise deployments require an administrator. This issue is fixed in version 7.3.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-77601?

2 open source packages ship an affected version, including openc3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openc3` | RubyGems | From 5.12.0 | 7.3.0 |
| `openc3` | RubyGems | From 5.12.0 | 7.3.0 |

## How do I fix CVE-2026-77601?

Upgrade openc3 to 7.3.0 or later.

## Is CVE-2026-77601 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77601 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77601 and fix it if it is affected.

What it is: CVE-2026-77601 is a high-severity command injection vulnerability in OpenC3 cosmos, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77601 exists.

Affected packages and fixed versions:
- openc3 (RubyGems): affected from 5.12.0; fixed in 7.3.0
- openc3 (RubyGems): affected from 5.12.0; fixed in 7.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77601/ (Markdown: https://insights.sbomify.com/CVE-2026-77601/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77601
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77601
- OSV: https://osv.dev/vulnerability/CVE-2026-77601

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77601/
Summaries are generated and may contain mistakes; the official description above is the record.
