# CVE-2026-77607: Semantic MediaWiki affected by Special:Ask table `sep` parameter reflected XSS

> An attacker can inject malicious HTML via the separator parameter in Semantic MediaWiki's Special:Ask table, leading to cross-site scripting.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-7xv3-gf2g-498h

## What is CVE-2026-77607?

CVE-2026-77607 is a medium-severity cross-site scripting vulnerability in SemanticMediaWiki, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Semantic MediaWiki is a free, open-source extension to MediaWiki that lets users store and query data within the wiki's pages. Prior to version 7.2.0, `sep` was inserted verbatim into HTML cell joins. This made it possible to inject HTML through the separator value. Version 7.2.0 fixes the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-77607?

2 open source packages ship an affected version, including mediawiki/semantic-media-wiki.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/semantic-media-wiki` | Packagist | All versions | 7.2.0 |
| `mediawiki/semantic-media-wiki` | Packagist | All versions | 7.2.0 |

## How do I fix CVE-2026-77607?

Upgrade mediawiki/semantic-media-wiki to 7.2.0 or later.

## Is CVE-2026-77607 being exploited?

There is no known exploitation of CVE-2026-77607 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77607 and fix it if it is affected.

What it is: CVE-2026-77607 is a medium-severity cross-site scripting vulnerability in SemanticMediaWiki, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-77607 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/semantic-media-wiki (Packagist): affected all versions; fixed in 7.2.0
- mediawiki/semantic-media-wiki (Packagist): affected all versions; fixed in 7.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77607/ (Markdown: https://insights.sbomify.com/CVE-2026-77607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77607
- OSV: https://osv.dev/vulnerability/CVE-2026-77607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77607/
Summaries are generated and may contain mistakes; the official description above is the record.
