# CVE-2026-77614: Opencast: Session fixation in login enables account takeover via crafted link

> Attackers can hijack user sessions via crafted links due to session fixation, leading to account takeover and data exposure in Opencast.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-6f53-jp7x-gg7p

## What is CVE-2026-77614?

CVE-2026-77614 is a high-severity authentication bypass vulnerability in opencast, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Opencast is a free, open-source platform to support the management of educational audio and video content. Prior to versions 19.7 and 20.2, the default security configuration in etc/security/mh_default_org.xml accepts a client-selected JSESSIONID from the ;jsessionid= URL path parameter and does not replace it when the victim logs in. An unauthenticated attacker can send a crafted link to a victim whose browser has no active Opencast session cookie, wait for the victim to authenticate, and then reuse the known identifier as the victim's authenticated session. This can expose the victim's data and actions and can produce full administrative account takeover when the victim is an administrator. This issue is fixed in versions 19.7 and 20.2.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-77614?


## How do I fix CVE-2026-77614?

No fix has been published for CVE-2026-77614 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-77614 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77614 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77614 and fix it if it is affected.

What it is: CVE-2026-77614 is a high-severity authentication bypass vulnerability in opencast, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77614 exists.

Affected product: opencast. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77614/ (Markdown: https://insights.sbomify.com/CVE-2026-77614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77614
- OSV: https://osv.dev/vulnerability/CVE-2026-77614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77614/
Summaries are generated and may contain mistakes; the official description above is the record.
