CVE-2026-77615 Paella Player: Stored XSS via caption cue text
Attackers can inject malicious scripts via closed caption cue text in Paella Player, potentially executing code in user browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-77615?
CVE-2026-77615 is a high-severity cross-site scripting vulnerability in opencast, published on 17 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Paella Player is a set of libraries to create a multi stream video player. Prior to Paella Player 2.12.11 (as used in Opencast prior to 19.7 and 20.2), there is a potential XSS attack though closed captions cue text. This vulnerability is fixed in 2.12.11.
Weakness: CWE-79
Which versions are affected by CVE-2026-77615?
6 open source packages ship an affected version, including org.opencastproject:opencast-engage-paella-player-7 and paella-core.
| Package | Affected | Fixed in |
|---|---|---|
org.opencastproject:opencast-engage-paella-player-7 Maven | All versions | 19.7 |
org.opencastproject:opencast-engage-paella-player-7 Maven | All versions | 19.7 |
org.opencastproject:opencast-engage-paella-player-7 Maven | From 20.0 | 20.2 |
org.opencastproject:opencast-engage-paella-player-7 Maven | From 20.0 | 20.2 |
paella-core npm | All versions | 1.50.6 |
paella-core npm | All versions | 1.50.6 |
How do I fix CVE-2026-77615?
Upgrade org.opencastproject:opencast-engage-paella-player-7 to a fixed version for your release line: 19.7 or 20.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-77615 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77615 exists.
Sources
Also known as GHSA-m6c8-jcw2-5r25.