# CVE-2026-77615: Paella Player: Stored XSS via caption cue text

> Attackers can inject malicious scripts via closed caption cue text in Paella Player, potentially executing code in user browsers.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-m6c8-jcw2-5r25

## What is CVE-2026-77615?

CVE-2026-77615 is a high-severity cross-site scripting vulnerability in opencast, published on 17 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Paella Player is a set of libraries to create a multi stream video player. Prior to Paella Player 2.12.11 (as used in Opencast prior to 19.7 and 20.2), there is a potential XSS attack though closed captions cue text. This vulnerability is fixed in 2.12.11.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-77615?

6 open source packages ship an affected version, including org.opencastproject:opencast-engage-paella-player-7 and paella-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-engage-paella-player-7` | Maven | All versions | 19.7 |
| `org.opencastproject:opencast-engage-paella-player-7` | Maven | All versions | 19.7 |
| `org.opencastproject:opencast-engage-paella-player-7` | Maven | From 20.0 | 20.2 |
| `org.opencastproject:opencast-engage-paella-player-7` | Maven | From 20.0 | 20.2 |
| `paella-core` | npm | All versions | 1.50.6 |
| `paella-core` | npm | All versions | 1.50.6 |

## How do I fix CVE-2026-77615?

Upgrade org.opencastproject:opencast-engage-paella-player-7 to a fixed version for your release line: 19.7 or 20.2.

## Is CVE-2026-77615 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77615 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77615 and fix it if it is affected.

What it is: CVE-2026-77615 is a high-severity cross-site scripting vulnerability in opencast, published on 17 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77615 exists.

Affected packages and fixed versions:
- org.opencastproject:opencast-engage-paella-player-7 (Maven): affected all versions; fixed in 19.7
- org.opencastproject:opencast-engage-paella-player-7 (Maven): affected all versions; fixed in 19.7
- org.opencastproject:opencast-engage-paella-player-7 (Maven): affected from 20.0; fixed in 20.2
- org.opencastproject:opencast-engage-paella-player-7 (Maven): affected from 20.0; fixed in 20.2
- paella-core (npm): affected all versions; fixed in 1.50.6
- paella-core (npm): affected all versions; fixed in 1.50.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77615/ (Markdown: https://insights.sbomify.com/CVE-2026-77615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77615
- OSV: https://osv.dev/vulnerability/CVE-2026-77615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77615/
Summaries are generated and may contain mistakes; the official description above is the record.
