CVE-2026-77634 CakePHP: SmtpTransport vulnerable to CRLF header injection
Attackers can inject CRLF characters into email headers via user-controlled data, potentially altering message structure or bypassing security checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-77634?
CVE-2026-77634 is a high-severity vulnerability in cakephp, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CakePHP is a rapid development framework for PHP. Prior to versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7 on their respective release lines, custom mail headers added with Message::setHeaders() or Message::addHeaders() do not have CRLF bytes removed, allowing header injection when user-controlled data is used in message headers. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.8, 5.2.14, and 5.3.7.
Weakness: CWE-93
Which versions are affected by CVE-2026-77634?
10 open source packages ship an affected version, including cakephp/cakephp.
| Package | Affected | Fixed in |
|---|---|---|
cakephp/cakephp Packagist | From 4.5.0 | 4.5.12 |
cakephp/cakephp Packagist | From 4.5.0 | 4.5.12 |
cakephp/cakephp Packagist | From 4.6.0 | 4.6.5 |
cakephp/cakephp Packagist | From 4.6.0 | 4.6.5 |
cakephp/cakephp Packagist | From 5.0.0 | 5.1.9 |
cakephp/cakephp Packagist | From 5.0.0 | 5.1.9 |
4 more packages
cakephp/cakephp Packagist | From 5.2.0 | 5.2.14 |
cakephp/cakephp Packagist | From 5.2.0 | 5.2.14 |
cakephp/cakephp Packagist | From 5.3.0 | 5.3.7 |
cakephp/cakephp Packagist | From 5.3.0 | 5.3.7 |
How do I fix CVE-2026-77634?
Upgrade cakephp/cakephp to a fixed version for your release line: 4.5.12, 4.6.5, 5.1.9 or 5.2.14.
Is CVE-2026-77634 being exploited?
There is no known exploitation of CVE-2026-77634 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1789384929, DEBIAN-CVE-2026-77634, GHSA-2qh5-382h-3jpc, UBUNTU-CVE-2026-77634.