CVE-2026-77635 CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver
Attackers can execute arbitrary SQL commands via the jsonPath parameter in CakePHP's FunctionsBuilder when using PostgresDriver.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-77635?
CVE-2026-77635 is a critical SQL injection vulnerability in cakephp, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.
Weakness: CWE-89
Which versions are affected by CVE-2026-77635?
12 open source packages ship an affected version, including cakephp/cakephp and cakephp/database.
| Package | Affected | Fixed in |
|---|---|---|
cakephp/cakephp Packagist | From 5.1.0 | 5.1.10 |
cakephp/cakephp Packagist | From 5.1.0 | 5.1.10 |
cakephp/cakephp Packagist | From 5.2.0 | 5.2.15 |
cakephp/cakephp Packagist | From 5.2.0 | 5.2.15 |
cakephp/cakephp Packagist | From 5.3.0 | 5.3.7 |
cakephp/cakephp Packagist | From 5.3.0 | 5.3.7 |
6 more packages
cakephp/database Packagist | From 5.1.0 | 5.1.10 |
cakephp/database Packagist | From 5.1.0 | 5.1.10 |
cakephp/database Packagist | From 5.2.0 | 5.2.15 |
cakephp/database Packagist | From 5.2.0 | 5.2.15 |
cakephp/database Packagist | From 5.3.0 | 5.3.7 |
cakephp/database Packagist | From 5.3.0 | 5.3.7 |
How do I fix CVE-2026-77635?
Upgrade cakephp/cakephp to a fixed version for your release line: 5.1.10, 5.2.15 or 5.3.7.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-77635 being exploited?
There is no known exploitation of CVE-2026-77635 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as DEBIAN-CVE-2026-77635, GHSA-fxf7-vhh8-7vpq, UBUNTU-CVE-2026-77635.