{"answers":{"affected":"12 open source packages ship an affected version, including cakephp/cakephp and cakephp/database.","exploited":"There is no known exploitation of CVE-2026-77635 in the wild and no public exploit code.","fix":"Upgrade cakephp/cakephp to a fixed version for your release line: 5.1.10, 5.2.15 or 5.3.7.","what":"CVE-2026-77635 is a critical SQL injection vulnerability in cakephp, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-77635 and fix it if it is affected.\n\nWhat it is: CVE-2026-77635 is a critical SQL injection vulnerability in cakephp, published on 24 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-77635 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected from 5.1.0; fixed in 5.1.10\n- cakephp/cakephp (Packagist): affected from 5.1.0; fixed in 5.1.10\n- cakephp/cakephp (Packagist): affected from 5.2.0; fixed in 5.2.15\n- cakephp/cakephp (Packagist): affected from 5.2.0; fixed in 5.2.15\n- cakephp/cakephp (Packagist): affected from 5.3.0; fixed in 5.3.7\n- cakephp/cakephp (Packagist): affected from 5.3.0; fixed in 5.3.7\n- cakephp/database (Packagist): affected from 5.1.0; fixed in 5.1.10\n- cakephp/database (Packagist): affected from 5.1.0; fixed in 5.1.10\n- cakephp/database (Packagist): affected from 5.2.0; fixed in 5.2.15\n- cakephp/database (Packagist): affected from 5.2.0; fixed in 5.2.15\n- cakephp/database (Packagist): affected from 5.3.0; fixed in 5.3.7\n- cakephp/database (Packagist): affected from 5.3.0; fixed in 5.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-77635/ (Markdown: https://insights.sbomify.com/CVE-2026-77635/index.md)","id":"CVE-2026-77635","markdown":"https://insights.sbomify.com/CVE-2026-77635/index.md","name":"CVE-2026-77635","record":{"aliases":["DEBIAN-CVE-2026-77635","GHSA-fxf7-vhh8-7vpq","UBUNTU-CVE-2026-77635"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can execute arbitrary SQL commands via the jsonPath parameter in CakePHP's FunctionsBuilder when using PostgresDriver.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-09-19","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-09-19T20:48:37Z","kind":"github_poc","ref":"https://github.com/abraxas/CVE-2026-77635","stars":0,"title":"CVE-2026-77635 - CakePHP - Critical 9.2 - Unauthenticated GET /?path= - SQL Injection"}],"tier":"poc_unverified"},"has_fix":true,"headline":"CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver","id":"CVE-2026-77635","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":12,"n_references":7,"next":{"headline":"Cloudreve: Privilege Scope Bypass: State-Mutating Admin Operations Accessible via Read-Only OAuth Scope","id":"CVE-2026-77637"},"packages":[{"ecosystem":"Packagist","fixed":["5.1.10"],"introduced":["5.1.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.1.10"],"introduced":["5.1.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.2.15"],"introduced":["5.2.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.2.15"],"introduced":["5.2.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.3.7"],"introduced":["5.3.0"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.3.7"],"introduced":["5.3.0"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.1.10"],"introduced":["5.1.0"],"last_affected":[],"package":"cakephp/database","purl":null,"source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.1.10"],"introduced":["5.1.0"],"last_affected":[],"package":"cakephp/database","purl":"pkg:composer/cakephp/database","source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.2.15"],"introduced":["5.2.0"],"last_affected":[],"package":"cakephp/database","purl":null,"source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.2.15"],"introduced":["5.2.0"],"last_affected":[],"package":"cakephp/database","purl":"pkg:composer/cakephp/database","source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.3.7"],"introduced":["5.3.0"],"last_affected":[],"package":"cakephp/database","purl":null,"source":"GHSA-fxf7-vhh8-7vpq"},{"ecosystem":"Packagist","fixed":["5.3.7"],"introduced":["5.3.0"],"last_affected":[],"package":"cakephp/database","purl":"pkg:composer/cakephp/database","source":"GHSA-fxf7-vhh8-7vpq"}],"prev":{"headline":"CakePHP: SmtpTransport vulnerable to CRLF header injection","id":"CVE-2026-77634"},"products":["cakephp","cakephp/database"],"published":"2026-08-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-25","vendors":["cakephp"]},"summary":"Attackers can execute arbitrary SQL commands via the jsonPath parameter in CakePHP's FunctionsBuilder when using PostgresDriver.","url":"https://insights.sbomify.com/CVE-2026-77635/"}