{"answers":{"affected":"1 open source package ship an affected version, including tomcat.","exploited":"There is no known exploitation of CVE-2026-77756 in the wild and no public exploit code.","fix":"Upgrade tomcat to a fixed version for your release line: 9.0.45, 9.0.122, 10.1.60 or 11.0.26.","what":"CVE-2026-77756 is a low-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-77756 and fix it if it is affected.\n\nWhat it is: CVE-2026-77756 is a low-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-77756 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tomcat (Bitnami): affected from 8.5.67; fixed in 9.0.45, 9.0.122, 10.1.60, 11.0.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-77756/ (Markdown: https://insights.sbomify.com/CVE-2026-77756/index.md)","id":"CVE-2026-77756","markdown":"https://insights.sbomify.com/CVE-2026-77756/index.md","name":"CVE-2026-77756","record":{"aliases":["BIT-tomcat-2026-77756","DEBIAN-CVE-2026-77756","GHSA-gpfr-7w77-mp48","MINI-j72f-7557-v57c","MINI-m2wv-j99f-26xf","MINI-w6v5-g8rj-5h9v","UBUNTU-CVE-2026-77756"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Tomcat","requires_auth":"none","summary":"Attackers can cause request failures for other users via HTTP request smuggling when Tomcat is behind a reverse proxy.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache Tomcat caused by processing the transfer-encoding header for an HTTP/1.0 request may allow an attacker to cause one request from another user to fail when Tomcat is located behind a reverse proxy.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.47 through 9.0.121.\n\nThe following versions were EOL at the time the CVE was created but are \nknown to be affected: from 8.5.67 through 8.5.100. Other unsupported versions may also be affected.\n\nUsers are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Tomcat: Transfer-Encoding honored for HTTP/1.0 requests","id":"CVE-2026-77756","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"other","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Directorist 8.5 - 8.9.2 - Subscriber+ Arbitrary Image Move via REST v2 Listing Submission","id":"CVE-2026-77757"},"packages":[{"ecosystem":"Bitnami","fixed":["9.0.45","9.0.122","10.1.60","11.0.26"],"introduced":["8.5.67","9.0.47","10.1.0","11.0.0"],"last_affected":[],"package":"tomcat","purl":"pkg:bitnami/tomcat","source":"BIT-tomcat-2026-77756"}],"prev":{"headline":"Denial of Service in MISP-STIX Import via Malformed or Oversized STIX Documents in misp-stix library","id":"CVE-2026-77755"},"products":["Apache Tomcat"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause request failures for other users via HTTP request smuggling when Tomcat is behind a reverse proxy.","url":"https://insights.sbomify.com/CVE-2026-77756/"}