# CVE-2026-77762: Apache Tomcat: Stale HPACK emitter injects trailers into recycled pooled Request

> An attacker can inject HTTP/2 trailer fields into other requests due to a race condition in Apache Tomcat's HPACK emitter.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** BIT-tomcat-2026-77762, DEBIAN-CVE-2026-77762, GHSA-28v4-2v86-58cc, MINI-6gq2-g7p9-wwf2, MINI-qpmw-2w7p-xg6g, MINI-rmvr-4m5g-j37v, UBUNTU-CVE-2026-77762

## What is CVE-2026-77762?

CVE-2026-77762 is a high-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat allows an attacker to inject trailer fields into another HTTP/2 request.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.39 through 9.0.121.

The following versions were EOL at the time the CVE was created but are 
known to be affected: from 8.5.59 through 8.5.100. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.26, 10.1.60, 9.0.122, which fix the issue.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-77762?

1 open source package ship an affected version, including tomcat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | From 8.56.59 | 9.0.122, 10.1.60, 11.0.26 |

## How do I fix CVE-2026-77762?

Upgrade tomcat to a fixed version for your release line: 9.0.122, 10.1.60 or 11.0.26.

## Is CVE-2026-77762 being exploited?

There is no known exploitation of CVE-2026-77762 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77762 and fix it if it is affected.

What it is: CVE-2026-77762 is a high-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-77762 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected from 8.56.59; fixed in 9.0.122, 10.1.60, 11.0.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77762/ (Markdown: https://insights.sbomify.com/CVE-2026-77762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77762
- OSV: https://osv.dev/vulnerability/CVE-2026-77762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77762/
Summaries are generated and may contain mistakes; the official description above is the record.
