CVE-2026-77883 Apache Syncope: Information disclosure via one-hop JEXL navigation past the JexlContextBuilder name denylist

Medium 4.9 Published Updated

Administrators can exploit JEXL expressions to access sensitive user data, including hashed credentials, bypassing intended access controls.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-77883?

CVE-2026-77883 is a medium-severity vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Exposure of sensitive information through data queries vulnerability in Apache Syncope.

An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access LinkedAccount's (if present) or Manager's (if defined) sensitive information, possibly including hashed credentials.

This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Weakness: CWE-202

Which versions are affected by CVE-2026-77883?

How do I fix CVE-2026-77883?

No fix has been published for CVE-2026-77883 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-77883 being exploited?

There is no known exploitation of CVE-2026-77883 in the wild and no public exploit code.

Sources

Also known as GHSA-pjhv-6xm9-9cxw.

Is CVE-2026-77883 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free