# CVE-2026-7790: Unbounded chunk-size hex digits in cowlib cause quadratic CPU and memory DoS

> Remote attackers can cause denial of service via CPU and memory exhaustion by sending crafted chunked HTTP requests to applications using the cowlib library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 26 May 2026
- **Also known as:** AZL-86790, DEBIAN-CVE-2026-7790, EEF-CVE-2026-7790, GHSA-32p9-57cr-4x65, UBUNTU-CVE-2026-7790

## What is CVE-2026-7790?

CVE-2026-7790 is a high-severity denial of service vulnerability in ninenines cowlib, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled Resource Consumption vulnerability in ninenines cowlib (cow_http_te module) allows Excessive Allocation.

The chunked transfer-encoding parser in cow_http_te accepts an unbounded number of hex digits in the chunk-size field. Each digit causes a bignum multiplication (Len * 16 + digit), so parsing N hex digits requires O(N²) CPU work and O(N) memory. Additionally, when input is drip-fed, the parser discards the accumulated length on each partial read and restarts from zero on resumption, raising the cost to O(N³). An unauthenticated remote attacker can exploit this by sending an HTTP/1.1 request with Transfer-Encoding: chunked and a very long chunk-size hex string to cause denial of service through CPU exhaustion and memory amplification.

This vulnerability is associated with program file src/cow_http_te.erl and program routines cow_http_te:stream_chunked/2, cow_http_te:chunked_len/4.

This issue affects cowlib: from 0.6.0 before 2.16.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-7790?

3 open source packages ship an affected version, including cowlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cowlib` | Hex | From 0.6.0 | 2.16.1 |
| `cowlib` | Hex | From 0.6.0 | 2.16.1 |
| `cowlib` | Hex | From 0.6.0 | 2.16.1 |

Products: Ninenines Cowlib.

## How do I fix CVE-2026-7790?

Upgrade cowlib to 2.16.1 or later.

## Is CVE-2026-7790 being exploited?

There is no known exploitation of CVE-2026-7790 in the wild and no public exploit code.

## Other vulnerabilities in ninenines cowlib

- [CVE-2026-43966](https://insights.sbomify.com/CVE-2026-43966/): HTTP Response Splitting via Non-VCHAR Bytes in cow_http_struct_hd:escape_string/2 (medium 6.3)
- [CVE-2026-43968](https://insights.sbomify.com/CVE-2026-43968/): CR Injection in SSE Encoder Enables Event Splitting via cow_sse:event/1 (medium 6.3)
- [CVE-2026-43969](https://insights.sbomify.com/CVE-2026-43969/): Cookie Request Header Injection via Unvalidated Encoder in cow_cookie:cookie/1 (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7790 and fix it if it is affected.

What it is: CVE-2026-7790 is a high-severity denial of service vulnerability in ninenines cowlib, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7790 in the wild and no public exploit code.

Affected packages and fixed versions:
- cowlib (Hex): affected from 0.6.0; fixed in 2.16.1
- cowlib (Hex): affected from 0.6.0; fixed in 2.16.1
- cowlib (Hex): affected from 0.6.0; fixed in 2.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7790/ (Markdown: https://insights.sbomify.com/CVE-2026-7790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7790
- OSV: https://osv.dev/vulnerability/CVE-2026-7790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7790/
Summaries are generated and may contain mistakes; the official description above is the record.
