# CVE-2026-77956: EEx template evaluation of prompt content in AshAi enables remote code execution

> Remote unauthenticated attackers can execute arbitrary Elixir code via EEx template injection in AshAi prompt actions.

- **Severity:** High 8.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** EEF-CVE-2026-77956, GHSA-2g59-hg7m-qc83

## What is CVE-2026-77956?

CVE-2026-77956 is a high-severity code injection vulnerability in ash-project ash_ai, published on 31 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Improper Control of Generation of Code (Code Injection) vulnerability in ash-project ash_ai allows a remote, unauthenticated client to execute arbitrary Elixir code.

AshAi.Actions.Prompt evaluates prompt content through EEx.eval_string/2. The documented prompt: fn input, context -> ... end form lets the prompt content be built from action arguments, so when a prompt action's text incorporates request data, that attacker-controlled text is compiled and run as an EEx template (Elixir source). Content such as <%= System.cmd(...) %> therefore executes on the server before any model request is made, requiring no authentication beyond reaching a prompt action. The fix stops evaluating function-supplied prompt content as EEx; only statically configured templates are evaluated.

This issue affects ash_ai: from 0.1.0 before 1.0.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-77956?

1 open source package ship an affected version, including ash_ai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_ai` | Hex | From 0.1.0 | 1.0.0 |

## How do I fix CVE-2026-77956?

Upgrade ash_ai to 1.0.0 or later.

## Is CVE-2026-77956 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77956 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77956 and fix it if it is affected.

What it is: CVE-2026-77956 is a high-severity code injection vulnerability in ash-project ash_ai, published on 31 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77956 exists.

Affected packages and fixed versions:
- ash_ai (Hex): affected from 0.1.0; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77956/ (Markdown: https://insights.sbomify.com/CVE-2026-77956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77956
- OSV: https://osv.dev/vulnerability/CVE-2026-77956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77956/
Summaries are generated and may contain mistakes; the official description above is the record.
