# CVE-2026-77970: Sensitive fields nested in embedded values are not redacted in AshPaperTrail versions

> Attackers with read access can recover sensitive nested data from version history because redaction logic fails to descend into embedded resources.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** EEF-CVE-2026-77970, GHSA-v645-6jm6-cgpj

## What is CVE-2026-77970?

CVE-2026-77970 is a medium-severity vulnerability in ash-project ash_paper_trail, published on 30 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cleartext Storage of Sensitive Information vulnerability in ash-project ash_paper_trail allows an attacker with read access to the generated version resource to recover sensitive values nested inside embedded resources, unions, or lists.

sensitive_attributes :redact and :ignore only act on the tracked resource's top-level attributes. maybe_redact_changes/3 and the stored-action-input path in AshPaperTrail.Resource.Changes.CreateNewVersion derive the sensitive set from the resource's own attributes and never descend into embedded, union, or list values, so a non-sensitive attribute or action argument that holds an embed with a sensitive? field (for example an accepted credentials embed carrying a token) is written to the version table in cleartext.

This issue affects ash_paper_trail: from 0.3.0 before 0.7.0.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2026-77970?

1 open source package ship an affected version, including ash_paper_trail.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_paper_trail` | Hex | From 0.3.0 | 0.7.0 |

## How do I fix CVE-2026-77970?

Upgrade ash_paper_trail to 0.7.0 or later.

## Is CVE-2026-77970 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77970 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-77970 and fix it if it is affected.

What it is: CVE-2026-77970 is a medium-severity vulnerability in ash-project ash_paper_trail, published on 30 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-77970 exists.

Affected packages and fixed versions:
- ash_paper_trail (Hex): affected from 0.3.0; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-77970/ (Markdown: https://insights.sbomify.com/CVE-2026-77970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-77970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-77970
- OSV: https://osv.dev/vulnerability/CVE-2026-77970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-77970/
Summaries are generated and may contain mistakes; the official description above is the record.
