# CVE-2026-7813: pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode

> Authenticated users can access other users' data and escalate privileges to execute arbitrary commands in server mode.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-h2x2-q2mc-24gw, PYSEC-2026-452

## What is CVE-2026-7813?

CVE-2026-7813 is a critical missing authorization vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authorization vulnerability in pgAdmin 4 server mode affecting Server Groups, Servers, Shared Servers, Background Processes, and Debugger modules.

Multiple endpoints fetched user-owned objects without filtering by the requesting user's identity. An authenticated user could access another user's private servers, server groups, background processes, and debugger function arguments by guessing object IDs.

Additionally, the Shared Servers feature contained multiple issues including credential leakage (passexec_cmd, passfile, SSL keys), privilege escalation via writable passexec_cmd (a shell command executed when establishing the connection) allowing arbitrary command execution in the owner's process context, and owner-data corruption via SQLAlchemy session mutations. Several owner-only fields (passexec_cmd, passexec_expiration, db_res, db_res_type) were writable by non-owners through the API, and additional fields (kerberos_conn, tags, post_connection_sql) lacked per-user persistence so non-owner edits mutated the owner's record.

Fix centralises access control via a new server_access module, scopes all user-owned models with a UserScopedMixin, returns HTTP 410 from connection_manager when access is denied in server mode, suppresses owner-only fields for non-owners across the merge / API response / ServerManager paths, and adds an explicit owner-only write guard. The remediation landed in two pull requests; both are referenced.

This issue affects pgAdmin 4: before 9.15.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-7813?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2026-7813?

Upgrade pgadmin4 to 9.15 or later.

## Is CVE-2026-7813 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7813 exists.

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7813 and fix it if it is affected.

What it is: CVE-2026-7813 is a critical missing authorization vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7813 exists.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7813/ (Markdown: https://insights.sbomify.com/CVE-2026-7813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7813
- OSV: https://osv.dev/vulnerability/CVE-2026-7813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7813/
Summaries are generated and may contain mistakes; the official description above is the record.
