# CVE-2026-7814: pgAdmin 4: Stored XSS via crafted PostgreSQL object names in Browser Tree and Explain Visualizer

> Attacker can execute arbitrary JavaScript in pgAdmin users' browsers via malicious PostgreSQL object names, potentially leading to session hijacking or data theft.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-6p2c-69cv-3fxq, PYSEC-2026-2866

## What is CVE-2026-7814?

CVE-2026-7814 is a medium-severity cross-site scripting vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Stored cross-site scripting (XSS) vulnerability in pgAdmin 4 Browser Tree and Explain Visualizer modules.

User-controlled PostgreSQL object names (database, schema, table, column, etc.) were assigned to DOM elements via innerHTML, allowing crafted object names containing HTML markup to execute attacker-supplied JavaScript in the browser of any pgAdmin user who navigated to or executed EXPLAIN over the malicious object.

Fix replaces innerHTML with textContent.

This issue affects pgAdmin 4: before 9.15.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-7814?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2026-7814?

Upgrade pgadmin4 to 9.15 or later.

## Is CVE-2026-7814 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7814 exists.

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7814 and fix it if it is affected.

What it is: CVE-2026-7814 is a medium-severity cross-site scripting vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-7814 exists.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7814/ (Markdown: https://insights.sbomify.com/CVE-2026-7814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7814
- OSV: https://osv.dev/vulnerability/CVE-2026-7814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7814/
Summaries are generated and may contain mistakes; the official description above is the record.
