# CVE-2026-7816: pgAdmin 4: OS command injection in Import/Export query export via psql metacommand breakout

> Authenticated users can execute arbitrary OS commands or write files on the pgAdmin server via unsanitized input in the Import/Export query export feature.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-j74f-g7vx-fh4x, PYSEC-2026-2870

## What is CVE-2026-7816?

CVE-2026-7816 is a high-severity command injection vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OS command injection (CWE-78) vulnerability in pgAdmin 4 Import/Export query export.

User-supplied input was interpolated directly into a psql \copy metacommand template without sanitization. An authenticated user could inject ") TO PROGRAM 'cmd'" to break out of the \copy (...) context and achieve arbitrary command execution on the pgAdmin server, or ") TO '/path'" for arbitrary file write. Additional fields (format, on_error, log_verbosity) were also raw-interpolated and exploitable.

Fix adds a parens-balance parser modeled on psql's strtokx tokenizer, allow-lists format/on_error/log_verbosity, rejects null bytes in the query, and tightens type and gating checks.

This issue affects pgAdmin 4: before 9.15.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-7816?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2026-7816?

Upgrade pgadmin4 to 9.15 or later.

## Is CVE-2026-7816 being exploited?

There is no known exploitation of CVE-2026-7816 in the wild and no public exploit code.

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7816 and fix it if it is affected.

What it is: CVE-2026-7816 is a high-severity command injection vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7816 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7816/ (Markdown: https://insights.sbomify.com/CVE-2026-7816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7816
- OSV: https://osv.dev/vulnerability/CVE-2026-7816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7816/
Summaries are generated and may contain mistakes; the official description above is the record.
