{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-7817 in the wild and no public exploit code.","fix":"Upgrade pgadmin4 to 9.15 or later.","what":"CVE-2026-7817 is a high-severity server-side request forgery vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-7817 and fix it if it is affected.\n\nWhat it is: CVE-2026-7817 is a high-severity server-side request forgery vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-7817 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 9.15\n- pgadmin4 (PyPI): affected all versions; fixed in 9.15\n- pgadmin4 (PyPI): affected all versions; fixed in 9.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-7817/ (Markdown: https://insights.sbomify.com/CVE-2026-7817/index.md)","id":"CVE-2026-7817","markdown":"https://insights.sbomify.com/CVE-2026-7817/index.md","name":"CVE-2026-7817","record":{"aliases":["GHSA-p58c-q354-6c4f","PYSEC-2026-2871"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL management tool","requires_auth":"low_privilege","summary":"Authenticated users can read arbitrary server files or trigger SSRF via LLM API configuration endpoints in pgAdmin 4.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-552","name":"Files or Directories Accessible to External Parties"}],"description":"Local file inclusion (LFI) and server-side request forgery (SSRF) vulnerabilities in pgAdmin 4 LLM API configuration endpoints.\n\nUser-supplied api_key_file and api_url preferences were passed to the LLM provider clients without validation. An authenticated user could read arbitrary server-side files by pointing api_key_file at any path readable by the pgAdmin process, or coerce pgAdmin into making requests to internal targets (e.g. cloud metadata services such as 169.254.169.254) by setting api_url, exploiting the chat path and model-list endpoints.\n\nFix restricts api_key_file to the user's private storage (server mode) or home directory (desktop mode), enforces a printable-ASCII key shape and a 1024-byte read cap, and gates api_url against a configurable allow-list (config.ALLOWED_LLM_API_URLS) at every entry point.\n\nThis issue affects pgAdmin 4: before 9.15.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pgAdmin 4: Local file inclusion and server-side request forgery in LLM API configuration endpoints","id":"CVE-2026-7817","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"pgAdmin 4: Unsafe deserialization (CWE-502) in file-backed session manager leads to remote code execution","id":"CVE-2026-7818"},"packages":[{"ecosystem":"PyPI","fixed":["9.15"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-p58c-q354-6c4f"},{"ecosystem":"PyPI","fixed":["9.15"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-p58c-q354-6c4f"},{"ecosystem":"PyPI","fixed":["9.15"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-2871"}],"prev":{"headline":"pgAdmin 4: OS command injection in Import/Export query export via psql metacommand breakout","id":"CVE-2026-7816"},"products":["pgAdmin 4"],"published":"2026-05-11","related":[{"cvss_score":9.9,"headline":"pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment","id":"CVE-2025-2945","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":9.9,"headline":"OAuth2 client id and secret exposed through the web browser in pgAdmin 4","id":"CVE-2024-9014","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.5,"headline":"Deserialization in pgAdmin 4","id":"CVE-2026-12046","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"SQL injection in pgAdmin 4","id":"CVE-2026-17351","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"Command injection in pgAdmin 4","id":"CVE-2026-17566","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"pgAdmin 4: AI Assistant read-only transaction bypass allows unauthorised writes and remote code execution","id":"CVE-2026-12045","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode","id":"CVE-2026-7813","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["pgadmin.org"]},"summary":"Authenticated users can read arbitrary server files or trigger SSRF via LLM API configuration endpoints in pgAdmin 4.","url":"https://insights.sbomify.com/CVE-2026-7817/"}