# CVE-2026-7818: pgAdmin 4: Unsafe deserialization (CWE-502) in file-backed session manager leads to remote code execution

> An authenticated user with write access to the sessions directory can achieve remote code execution via unsafe deserialization in pgAdmin 4.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-4rhg-h8f2-v4jm, PYSEC-2026-2865

## What is CVE-2026-7818?

CVE-2026-7818 is a high-severity unsafe deserialization vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Deserialization of untrusted data (CWE-502) in pgAdmin 4 FileBackedSessionManager.

The session manager performed unsafe deserialization of session-file contents (using Python's standard object-serialization module) before performing any HMAC integrity check. Any file dropped into the sessions directory was deserialized unconditionally. An authenticated user with write access to the sessions directory (whether by misconfiguration or in combination with another path-traversal flaw) could plant a crafted serialized payload to achieve operating-system level remote code execution under the pgAdmin process identity.

Fix prepends a 64-byte hex SHA-256 HMAC over the session body, computed with SECRET_KEY, and verifies it via hmac.compare_digest before any deserialization. The check is raised (rather than asserted) on empty SECRET_KEY so it is not stripped under -O.

This issue affects pgAdmin 4: before 9.15.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-7818?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |
| `pgadmin4` | PyPI | All versions | 9.15 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2026-7818?

Upgrade pgadmin4 to 9.15 or later.

## Is CVE-2026-7818 being exploited?

There is no known exploitation of CVE-2026-7818 in the wild and no public exploit code.

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7818 and fix it if it is affected.

What it is: CVE-2026-7818 is a high-severity unsafe deserialization vulnerability in pgadmin.org pgAdmin 4, published on 11 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-7818 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15
- pgadmin4 (PyPI): affected all versions; fixed in 9.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7818/ (Markdown: https://insights.sbomify.com/CVE-2026-7818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7818
- OSV: https://osv.dev/vulnerability/CVE-2026-7818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7818/
Summaries are generated and may contain mistakes; the official description above is the record.
