{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-78214 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-78214 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-78214 is a medium-severity authentication bypass vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-78214 and fix it if it is affected.\n\nWhat it is: CVE-2026-78214 is a medium-severity authentication bypass vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-78214 in the wild and no public exploit code.\n\nAffected product: Apache DolphinScheduler. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-78214/ (Markdown: https://insights.sbomify.com/CVE-2026-78214/index.md)","id":"CVE-2026-78214","markdown":"https://insights.sbomify.com/CVE-2026-78214/index.md","name":"CVE-2026-78214","record":{"aliases":["GHSA-68pc-ppw3-f56j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache DolphinScheduler","requires_auth":"none","summary":"Remote attackers can bypass authentication on Actuator endpoints via percent-encoded paths, exposing sensitive configuration and management data.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"An authentication bypass vulnerability exists in the protection of Actuator endpoints. The application determines whether authentication is required by matching the incoming request path against protected Actuator paths. By sending a specially crafted request containing a percent-encoded path, a remote unauthenticated attacker can cause the security check to fail to recognize the request as targeting a protected endpoint.\n\nAs a result, the attacker may bypass authentication and access otherwise restricted Actuator endpoints. Successful exploitation may expose operational or configuration information and, depending on the enabled endpoints and application configuration, allow access to sensitive management functionality.\n\nThis issue affects Apache DolphinScheduler: before 3.4.3.\n\nUsers are recommended to upgrade to version 3.4.3, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apache DolphinScheduler: Actuator Endpoint Authentication Bypass via Percent-Encoded Paths","id":"CVE-2026-78214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"AshLua eval read operations can read field-policy-protected fields via aggregates","id":"CVE-2026-78216"},"packages":[],"prev":{"headline":"Hepta Platforms｜Heptabase - Stored Cross-Site Scripting","id":"CVE-2026-78213"},"products":["Apache DolphinScheduler"],"published":"2026-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can bypass authentication on Actuator endpoints via percent-encoded paths, exposing sensitive configuration and management data.","url":"https://insights.sbomify.com/CVE-2026-78214/"}