# CVE-2026-78214: Apache DolphinScheduler: Actuator Endpoint Authentication Bypass via Percent-Encoded Paths

> Remote attackers can bypass authentication on Actuator endpoints via percent-encoded paths, exposing sensitive configuration and management data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-68pc-ppw3-f56j

## What is CVE-2026-78214?

CVE-2026-78214 is a medium-severity authentication bypass vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An authentication bypass vulnerability exists in the protection of Actuator endpoints. The application determines whether authentication is required by matching the incoming request path against protected Actuator paths. By sending a specially crafted request containing a percent-encoded path, a remote unauthenticated attacker can cause the security check to fail to recognize the request as targeting a protected endpoint.

As a result, the attacker may bypass authentication and access otherwise restricted Actuator endpoints. Successful exploitation may expose operational or configuration information and, depending on the enabled endpoints and application configuration, allow access to sensitive management functionality.

This issue affects Apache DolphinScheduler: before 3.4.3.

Users are recommended to upgrade to version 3.4.3, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-78214?


## How do I fix CVE-2026-78214?

No fix has been published for CVE-2026-78214 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-78214 being exploited?

There is no known exploitation of CVE-2026-78214 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78214 and fix it if it is affected.

What it is: CVE-2026-78214 is a medium-severity authentication bypass vulnerability in Apache DolphinScheduler, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-78214 in the wild and no public exploit code.

Affected product: Apache DolphinScheduler. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78214/ (Markdown: https://insights.sbomify.com/CVE-2026-78214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78214
- OSV: https://osv.dev/vulnerability/CVE-2026-78214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78214/
Summaries are generated and may contain mistakes; the official description above is the record.
