# CVE-2026-78216: AshLua eval read operations can read field-policy-protected fields via aggregates


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** EEF-CVE-2026-78216, GHSA-5whv-8rcp-x33j

## What is CVE-2026-78216?

CVE-2026-78216 is a medium-severity vulnerability in ash-project ash_lua, published on 8 Sep 2026. 

### Official description

AshLua exposes Ash read actions to Lua scripts run through an eval action. A read call accepts an operation (list, min, max, first, sum, avg) that builds an ad-hoc Ash.Query.Aggregate over a named field and returns its raw value.

Ash field policies redact forbidden fields on returned records (replacing them with %Ash.ForbiddenField{}), but that redaction does not apply to aggregate values. A script could therefore read a field the calling actor's field policies forbid by requesting it as an aggregate instead of as a field. This includes fields that are public? true but restricted per-actor by a field policy, such as sensitive PII. The prior hardening only enforced the exposed-field allow-list (field visibility), which is a separate axis from per-actor field-policy authorization.

The fix authorizes the aggregated field against the resource's field policies, so aggregating over a field the actor may not see is refused or scoped to the rows where it is visible.

This issue affects ash_lua: from 0.1.0 before 0.2.2.

Weakness: CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2026-78216?

1 open source package ship an affected version, including ash_lua.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_lua` | Hex | From 0.1.0 | 0.2.2 |

## How do I fix CVE-2026-78216?

Upgrade ash_lua to 0.2.2 or later.

## Is CVE-2026-78216 being exploited?

There is no known exploitation of CVE-2026-78216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78216 and fix it if it is affected.

What it is: CVE-2026-78216 is a medium-severity vulnerability in ash-project ash_lua, published on 8 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-78216 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash_lua (Hex): affected from 0.1.0; fixed in 0.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78216/ (Markdown: https://insights.sbomify.com/CVE-2026-78216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78216
- OSV: https://osv.dev/vulnerability/CVE-2026-78216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78216/
Summaries are generated and may contain mistakes; the official description above is the record.
