{"answers":{"affected":"1 open source package ship an affected version, including ash_ai.","exploited":"There is no known exploitation of CVE-2026-78230 in the wild and no public exploit code.","fix":"Upgrade ash_ai to 1.0.3 or later.","what":"CVE-2026-78230 is a medium-severity missing authorization vulnerability in ash-project ash_ai, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-78230 and fix it if it is affected.\n\nWhat it is: CVE-2026-78230 is a medium-severity missing authorization vulnerability in ash-project ash_ai, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-78230 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ash_ai (Hex): affected from 0.1.0; fixed in 1.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-78230/ (Markdown: https://insights.sbomify.com/CVE-2026-78230/index.md)","id":"CVE-2026-78230","markdown":"https://insights.sbomify.com/CVE-2026-78230/index.md","name":"CVE-2026-78230","record":{"aliases":["EEF-CVE-2026-78230","GHSA-v5rw-36x5-r5vx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ash AI library","requires_auth":"low_privilege","summary":"Attackers can bypass field-level security policies in AshAi to read sensitive data by using aggregate queries, exposing protected fields to unauthorized users.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1220","name":"Insufficient Granularity of Access Control"}],"description":"AshAi exposes Ash read actions to language-model tool calls. The read tool accepts an aggregate result type (min, max, sum, avg) that builds an ad-hoc Ash.Query.Aggregate over a named field and returns its raw value.\n\nAsh field policies redact forbidden fields on returned records (replacing them with %Ash.ForbiddenField{}), but that redaction does not apply to aggregate values. A tool caller could therefore read a field the calling actor's field policies forbid by requesting it as an aggregate; min/max in particular return an actual field value. This includes fields that are public? true but restricted per-actor by a field policy, such as sensitive PII. The tool's existing check only required the field to be public, which is a separate axis from per-actor field-policy authorization.\n\nThe fix authorizes the aggregated field against the resource's field policies, so aggregating over a field the actor may not see is refused or scoped to the rows where it is visible.\n\nThis issue affects ash_ai: from 0.1.0 before 1.0.3.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AshAi aggregate tool can read field-policy-protected fields","id":"CVE-2026-78230","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":5,"next":{"headline":"Gitea blind SSRF through OpenID assertion verification","id":"CVE-2026-78231"},"packages":[{"ecosystem":"Hex","fixed":["1.0.3"],"introduced":["0.1.0"],"last_affected":[],"package":"ash_ai","purl":"pkg:hex/ash_ai","source":"EEF-CVE-2026-78230"}],"prev":{"headline":"Image Scanner Driver for Linux contains an OS command injection vulnerability.","id":"CVE-2026-78229"},"products":["ash_ai"],"published":"2026-09-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-08","vendors":["ash-project"]},"summary":"Attackers can bypass field-level security policies in AshAi to read sensitive data by using aggregate queries, exposing protected fields to unauthorized users.","url":"https://insights.sbomify.com/CVE-2026-78230/"}