CVE-2026-78242 Apache APISIX: data-mask may fail to redact request headers in logger output

Medium 5.7 Published Updated

Attackers can view unmasked sensitive request headers in logs due to a data-mask plugin failure in Apache APISIX.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-78242?

CVE-2026-78242 is a medium-severity vulnerability in Apache APISIX, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Insertion of sensitive information into log file vulnerability in Apache APISIX.

This vulnerability can cause the unmasked header value to be written to the log sink under a certain response structure. 

This issue affects Apache APISIX: 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Weakness: CWE-532

Which versions are affected by CVE-2026-78242?

1 open source package ship an affected version, including apisix.

PackageAffectedFixed in
apisix BitnamiFrom 3.17.03.18.0

How do I fix CVE-2026-78242?

Upgrade apisix to 3.18.0 or later.

Is CVE-2026-78242 being exploited?

There is no known exploitation of CVE-2026-78242 in the wild and no public exploit code.

Sources

Also known as BIT-apisix-2026-78242, GHSA-6wpw-9w4j-xv6c, MINI-5qhj-xfmw-cwq4.

Is CVE-2026-78242 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free