{"answers":{"affected":"1 open source package ship an affected version, including apisix.","exploited":"There is no known exploitation of CVE-2026-78242 in the wild and no public exploit code.","fix":"Upgrade apisix to 3.18.0 or later.","what":"CVE-2026-78242 is a medium-severity vulnerability in Apache APISIX, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-78242 and fix it if it is affected.\n\nWhat it is: CVE-2026-78242 is a medium-severity vulnerability in Apache APISIX, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-78242 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apisix (Bitnami): affected from 3.17.0; fixed in 3.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-78242/ (Markdown: https://insights.sbomify.com/CVE-2026-78242/index.md)","id":"CVE-2026-78242","markdown":"https://insights.sbomify.com/CVE-2026-78242/index.md","name":"CVE-2026-78242","record":{"aliases":["BIT-apisix-2026-78242","GHSA-6wpw-9w4j-xv6c","MINI-5qhj-xfmw-cwq4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"API Gateway","requires_auth":"low_privilege","summary":"Attackers can view unmasked sensitive request headers in logs due to a data-mask plugin failure in Apache APISIX.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"Insertion of sensitive information into log file vulnerability in Apache APISIX.\n\nThis vulnerability can cause the unmasked header value to be written to the log sink under a certain response structure. \n\nThis issue affects Apache APISIX: 3.17.0.\n\nUsers are recommended to upgrade to version 3.18.0, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache APISIX: data-mask may fail to redact request headers in logger output","id":"CVE-2026-78242","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Apache YuniKorn: LDAP Group provider panics on lowercase attribute name","id":"CVE-2026-78243"},"packages":[{"ecosystem":"Bitnami","fixed":["3.18.0"],"introduced":["3.17.0"],"last_affected":[],"package":"apisix","purl":"pkg:bitnami/apisix","source":"BIT-apisix-2026-78242"}],"prev":{"headline":"Xiiaozet LK100W Missing Authentication for Critical Function","id":"CVE-2026-78239"},"products":["Apache APISIX"],"published":"2026-10-01","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-01","vendors":["Apache Software Foundation"]},"summary":"Attackers can view unmasked sensitive request headers in logs due to a data-mask plugin failure in Apache APISIX.","url":"https://insights.sbomify.com/CVE-2026-78242/"}