# CVE-2026-78242: Apache APISIX: data-mask may fail to redact request headers in logger output

> Attackers can view unmasked sensitive request headers in logs due to a data-mask plugin failure in Apache APISIX.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2026
- **Updated:** 1 Oct 2026
- **Also known as:** BIT-apisix-2026-78242, GHSA-6wpw-9w4j-xv6c, MINI-5qhj-xfmw-cwq4

## What is CVE-2026-78242?

CVE-2026-78242 is a medium-severity vulnerability in Apache APISIX, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Insertion of sensitive information into log file vulnerability in Apache APISIX.

This vulnerability can cause the unmasked header value to be written to the log sink under a certain response structure. 

This issue affects Apache APISIX: 3.17.0.

Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-78242?

1 open source package ship an affected version, including apisix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 3.17.0 | 3.18.0 |

## How do I fix CVE-2026-78242?

Upgrade apisix to 3.18.0 or later.

## Is CVE-2026-78242 being exploited?

There is no known exploitation of CVE-2026-78242 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78242 and fix it if it is affected.

What it is: CVE-2026-78242 is a medium-severity vulnerability in Apache APISIX, published on 1 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-78242 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 3.17.0; fixed in 3.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78242/ (Markdown: https://insights.sbomify.com/CVE-2026-78242/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78242
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78242
- OSV: https://osv.dev/vulnerability/CVE-2026-78242

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78242/
Summaries are generated and may contain mistakes; the official description above is the record.
