CVE-2026-78318 Apache Syncope: Unauthenticated reflected XSS in Console and Enduser
An attacker can execute arbitrary JavaScript in the context of Apache Syncope users via malicious links on login pages, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2026-78318?
CVE-2026-78318 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Syncope.
The notification message, as optionally shown by Console's and Enduser's login pages can be instructed to display HTML tags with unsafe JS inline, via malicious HTTP link generation.
This issue affects Apache Syncope: from 4.0.4 through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-78318?
How do I fix CVE-2026-78318?
No fix has been published for CVE-2026-78318 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-78318 being exploited?
There is no known exploitation of CVE-2026-78318 in the wild and no public exploit code.
Sources
Also known as GHSA-3mx4-f6m3-9f3g.