{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-78318 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-78318 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-78318 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-78318 and fix it if it is affected.\n\nWhat it is: CVE-2026-78318 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-78318 in the wild and no public exploit code.\n\nAffected product: Apache Syncope. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-78318/ (Markdown: https://insights.sbomify.com/CVE-2026-78318/index.md)","id":"CVE-2026-78318","markdown":"https://insights.sbomify.com/CVE-2026-78318/index.md","name":"CVE-2026-78318","record":{"aliases":["GHSA-3mx4-f6m3-9f3g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Syncope","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in the context of Apache Syncope users via malicious links on login pages, potentially leading to session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Syncope.\n\nThe notification message, as optionally shown by Console's and Enduser's login pages can be instructed to display HTML tags with unsafe JS inline, via malicious HTTP link generation.\n\nThis issue affects Apache Syncope: from 4.0.4 through 4.0.7, from 4.1.0-M0 through 4.1.2.\n\nUsers are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apache Syncope: Unauthenticated reflected XSS in Console and Enduser","id":"CVE-2026-78318","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"TOCTOU Vulnerability in file exchange","id":"CVE-2026-78319"},"packages":[],"prev":{"headline":"DIAEnergie - SQL Injection","id":"CVE-2026-78317"},"products":["Apache Syncope"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-14","vendors":["Apache Software Foundation"]},"summary":"An attacker can execute arbitrary JavaScript in the context of Apache Syncope users via malicious links on login pages, potentially leading to session hijacking.","url":"https://insights.sbomify.com/CVE-2026-78318/"}