# CVE-2026-78318: Apache Syncope: Unauthenticated reflected XSS in Console and Enduser

> An attacker can execute arbitrary JavaScript in the context of Apache Syncope users via malicious links on login pages, potentially leading to session hijacking.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-3mx4-f6m3-9f3g

## What is CVE-2026-78318?

CVE-2026-78318 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Syncope.

The notification message, as optionally shown by Console's and Enduser's login pages can be instructed to display HTML tags with unsafe JS inline, via malicious HTTP link generation.

This issue affects Apache Syncope: from 4.0.4 through 4.0.7, from 4.1.0-M0 through 4.1.2.

Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-78318?


## How do I fix CVE-2026-78318?

No fix has been published for CVE-2026-78318 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-78318 being exploited?

There is no known exploitation of CVE-2026-78318 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78318 and fix it if it is affected.

What it is: CVE-2026-78318 is a medium-severity cross-site scripting vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-78318 in the wild and no public exploit code.

Affected product: Apache Syncope. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78318/ (Markdown: https://insights.sbomify.com/CVE-2026-78318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78318
- OSV: https://osv.dev/vulnerability/CVE-2026-78318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78318/
Summaries are generated and may contain mistakes; the official description above is the record.
