CVE-2026-78330 Apache Syncope: Privilege escalation for admin user via JWT authentication
Attackers can escalate privileges to admin if internal JWT authentication settings are disclosed, requiring an upgrade to secure the system.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-78330?
CVE-2026-78330 is a critical vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incorrect privilege assignment vulnerability in Apache Syncope.
When the configured JWKS settings for internal JWT authentication are disclosed (at least protocol and key), an attacker can obtain admin privileges after completing a successful authentication and obtaining a valid low-privileges JWT.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Weakness: CWE-266
Which versions are affected by CVE-2026-78330?
How do I fix CVE-2026-78330?
No fix has been published for CVE-2026-78330 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-78330 being exploited?
There is no known exploitation of CVE-2026-78330 in the wild and no public exploit code.
Sources
Also known as GHSA-w7wp-qc67-vgc8.