CVE-2026-78336 Apache Syncope: OIDCC4UI provider list discloses client secrets to any authenticated user
Authenticated users can retrieve OIDC client secrets from the provider list, exposing sensitive credentials regardless of their permissions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-78336?
CVE-2026-78336 is a high-severity vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insertion of sensitive information into sent data vulnerability in Apache Syncope.
Any authenticated user can query for the list of available OIDC providers configured for SSO with Console and Enduser. The returned payload contains all configuration settings, including client secrets, regardless of the entitlements owned by the caller.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Weakness: CWE-201
Which versions are affected by CVE-2026-78336?
How do I fix CVE-2026-78336?
No fix has been published for CVE-2026-78336 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-78336 being exploited?
There is no known exploitation of CVE-2026-78336 in the wild and no public exploit code.
Sources
Also known as GHSA-qx7m-8v34-28ww.