# CVE-2026-78414: Cross-site scripting in Nx Witness VMS Web Administration allows session token exfiltration via a rogue peer site name

> An adjacent attacker can steal administrator session tokens via XSS in the Web Administration interface, leading to account takeover.

- **Severity:** High 8.0 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** GHSA-237w-25vx-r57c

## What is CVE-2026-78414?

CVE-2026-78414 is a high-severity cross-site scripting vulnerability in Network Optix Nx Witness VMS, published on 24 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting in the Web Administration interface of Network Optix Nx Witness VMS before version 6.1.3 on Linux, Windows and MacOS allows an adjacent-network attacker to execute arbitrary JavaScript in the browser of an authenticated administrator and steal the administrator's session token, resulting in Administrator Account Takeover. An attacker who controls an Nx server on the same network segment can set that server's site name to a script payload, which executes when an administrator opens the "Merge with Another Site" dialog and the site selection list is displayed.Solution:

Update to Nx Witness VMS version 6.1.3 or later.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-78414?


## How do I fix CVE-2026-78414?

No fix has been published for CVE-2026-78414 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-78414 being exploited?

There is no known exploitation of CVE-2026-78414 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78414 and fix it if it is affected.

What it is: CVE-2026-78414 is a high-severity cross-site scripting vulnerability in Network Optix Nx Witness VMS, published on 24 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-78414 in the wild and no public exploit code.

Affected product: Network Optix Nx Witness VMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78414/ (Markdown: https://insights.sbomify.com/CVE-2026-78414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78414
- OSV: https://osv.dev/vulnerability/CVE-2026-78414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78414/
Summaries are generated and may contain mistakes; the official description above is the record.
