CVE-2026-78437 Apache Tomcat: HTTP/2 DoS via malformed request
A malformed HTTP/2 request in Apache Tomcat can cause other users' requests to fail, leading to a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-78437?
CVE-2026-78437 is a high-severity denial of service vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Incomplete cleanup vulnerability in Apache Tomcat allows a malformed request to potentially (depends on timing) cause one request from another user to fail.
This issue affects Apache Tomcat: from 11.0.19 through 11.0.25, from 10.1.53 through 10.1.59, from 9.0.116 through 9.0.121.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.
Weakness: CWE-459
Which versions are affected by CVE-2026-78437?
1 open source package ship an affected version, including tomcat.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | From 9.0.116 | 9.0.122, 10.1.60, 11.0.26 |
How do I fix CVE-2026-78437?
Upgrade tomcat to a fixed version for your release line: 9.0.122, 10.1.60 or 11.0.26.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-78437 being exploited?
There is no known exploitation of CVE-2026-78437 in the wild and no public exploit code.
Sources
Also known as BIT-tomcat-2026-78437, DEBIAN-CVE-2026-78437, GHSA-hvg5-8g86-xm44, MINI-p8hh-f3g5-cqqp, MINI-qq53-899p-6m39, MINI-w697-q898-mprq and 1 more.