# CVE-2026-78437: Apache Tomcat: HTTP/2 DoS via malformed request

> A malformed HTTP/2 request in Apache Tomcat can cause other users' requests to fail, leading to a denial of service.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** BIT-tomcat-2026-78437, DEBIAN-CVE-2026-78437, GHSA-hvg5-8g86-xm44, MINI-p8hh-f3g5-cqqp, MINI-qq53-899p-6m39, MINI-w697-q898-mprq, UBUNTU-CVE-2026-78437

## What is CVE-2026-78437?

CVE-2026-78437 is a high-severity denial of service vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Incomplete cleanup vulnerability in Apache Tomcat allows a malformed request to potentially (depends on timing) cause one request from another user to fail.

This issue affects Apache Tomcat: from 11.0.19 through 11.0.25, from 10.1.53 through 10.1.59, from 9.0.116 through 9.0.121.

Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2026-78437?

1 open source package ship an affected version, including tomcat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | From 9.0.116 | 9.0.122, 10.1.60, 11.0.26 |

## How do I fix CVE-2026-78437?

Upgrade tomcat to a fixed version for your release line: 9.0.122, 10.1.60 or 11.0.26.

## Is CVE-2026-78437 being exploited?

There is no known exploitation of CVE-2026-78437 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78437 and fix it if it is affected.

What it is: CVE-2026-78437 is a high-severity denial of service vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-78437 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected from 9.0.116; fixed in 9.0.122, 10.1.60, 11.0.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78437/ (Markdown: https://insights.sbomify.com/CVE-2026-78437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78437
- OSV: https://osv.dev/vulnerability/CVE-2026-78437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78437/
Summaries are generated and may contain mistakes; the official description above is the record.
