# CVE-2026-7860: Possible information disclosure of environment variables in Vaadin Build Plugins via Failed Frontend Build

> Failed frontend builds in Vaadin plugins expose environment variables, including secrets, in CI logs, requiring developers to upgrade to secure versions.

- **Severity:** Low 1.6 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N/E:U/S:N/AU:N/R:A/V:C/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-j8mx-j73w-9mxw

## What is CVE-2026-7860?

CVE-2026-7860 is a low-severity vulnerability in vaadin flow, published on 19 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A possible information disclosure vulnerability exists in the Vaadin Maven plugin and Vaadin Gradle plugin that exposes the full set of environment variables in build logs whenever the frontend build process exits with a non-zero status. Because the build environment may contain credentials supplied as secrets, any failed frontend build can expose those secrets in clear text in CI logs and archived build artifacts.

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

Product version
Vaadin 23.0.0 - 23.6.9
Vaadin 24.0.0 - 24.9.16
Vaadin 24.10.0 - 24.10.3
Vaadin 25.0.0 - 25.0.10
Vaadin 25.1.0 - 25.1.4

Mitigation
Upgrade to 23.6.10
Upgrade to 24.9.17 or newer
Upgrade to 24.10.4 or newer
Upgrade to 25.0.11 or newer
Upgrade to 25.1.5 or newer

Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, or 25 version.

ArtifactsMaven coordinatesVulnerable versionsFixed versioncom.vaadin:flow-plugin-base23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-plugin-base24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-plugin-base24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-plugin-base25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-plugin-base25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-maven-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-maven-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-maven-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-maven-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-maven-plugin25.1.0 - 25.1.4≥25.1.5com.vaadin:flow-gradle-plugin23.0.0 - 23.6.10≥23.6.11com.vaadin:flow-gradle-plugin24.0.0 - 24.9.17≥24.9.18com.vaadin:flow-gradle-plugin24.10.0 - 24.10.3≥24.10.4com.vaadin:flow-gradle-plugin25.0.0 - 25.0.11≥25.0.12com.vaadin:flow-gradle-plugin25.1.0 - 25.1.4≥25.1.5

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-7860?

28 open source packages ship an affected version, including com.vaadin:flow-maven-plugin, com.vaadin:flow-gradle-plugin and com.vaadin:flow-plugins.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:flow-maven-plugin` | Maven | From 23.0.0 | 23.6.11 |
| `com.vaadin:flow-maven-plugin` | Maven | From 23.0.0 | 23.6.11 |
| `com.vaadin:flow-maven-plugin` | Maven | From 24.0.0 | 24.9.18 |
| `com.vaadin:flow-maven-plugin` | Maven | From 24.0.0 | 24.9.18 |
| `com.vaadin:flow-maven-plugin` | Maven | From 24.10.0 | 24.10.4 |
| `com.vaadin:flow-maven-plugin` | Maven | From 24.10.0 | 24.10.4 |
| `com.vaadin:flow-maven-plugin` | Maven | From 25.0.0 | 25.0.12 |
| `com.vaadin:flow-maven-plugin` | Maven | From 25.0.0 | 25.0.12 |
| `com.vaadin:flow-maven-plugin` | Maven | From 25.1.0 | 25.1.5 |
| `com.vaadin:flow-maven-plugin` | Maven | From 25.1.0 | 25.1.5 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 24.0.0 | 24.9.18 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 24.0.0 | 24.9.18 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 24.10.0 | 24.10.4 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 24.10.0 | 24.10.4 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 25.0.0 | 25.0.12 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 25.0.0 | 25.0.12 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 25.1.0 | 25.1.5 |
| `com.vaadin:flow-gradle-plugin` | Maven | From 25.1.0 | 25.1.5 |
| `com.vaadin:flow-plugins` | Maven | From 23.0.0 | 23.6.11 |
| `com.vaadin:flow-plugins` | Maven | From 23.0.0 | 23.6.11 |
| `com.vaadin:flow-plugins` | Maven | From 24.0.0 | 24.9.18 |
| `com.vaadin:flow-plugins` | Maven | From 24.0.0 | 24.9.18 |
| `com.vaadin:flow-plugins` | Maven | From 24.10.0 | 24.10.4 |
| `com.vaadin:flow-plugins` | Maven | From 24.10.0 | 24.10.4 |
| `com.vaadin:flow-plugins` | Maven | From 25.0.0 | 25.0.12 |
| `com.vaadin:flow-plugins` | Maven | From 25.0.0 | 25.0.12 |
| `com.vaadin:flow-plugins` | Maven | From 25.1.0 | 25.1.5 |
| `com.vaadin:flow-plugins` | Maven | From 25.1.0 | 25.1.5 |

## How do I fix CVE-2026-7860?

Upgrade com.vaadin:flow-maven-plugin to a fixed version for your release line: 23.6.11, 24.9.18, 24.10.4 or 25.0.12.

## Is CVE-2026-7860 being exploited?

There is no known exploitation of CVE-2026-7860 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-7860 and fix it if it is affected.

What it is: CVE-2026-7860 is a low-severity vulnerability in vaadin flow, published on 19 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-7860 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:flow-maven-plugin (Maven): affected from 23.0.0; fixed in 23.6.11
- com.vaadin:flow-maven-plugin (Maven): affected from 23.0.0; fixed in 23.6.11
- com.vaadin:flow-maven-plugin (Maven): affected from 24.0.0; fixed in 24.9.18
- com.vaadin:flow-maven-plugin (Maven): affected from 24.0.0; fixed in 24.9.18
- com.vaadin:flow-maven-plugin (Maven): affected from 24.10.0; fixed in 24.10.4
- com.vaadin:flow-maven-plugin (Maven): affected from 24.10.0; fixed in 24.10.4
- com.vaadin:flow-maven-plugin (Maven): affected from 25.0.0; fixed in 25.0.12
- com.vaadin:flow-maven-plugin (Maven): affected from 25.0.0; fixed in 25.0.12
- com.vaadin:flow-maven-plugin (Maven): affected from 25.1.0; fixed in 25.1.5
- com.vaadin:flow-maven-plugin (Maven): affected from 25.1.0; fixed in 25.1.5
- com.vaadin:flow-gradle-plugin (Maven): affected from 24.0.0; fixed in 24.9.18
- com.vaadin:flow-gradle-plugin (Maven): affected from 24.0.0; fixed in 24.9.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-7860/ (Markdown: https://insights.sbomify.com/CVE-2026-7860/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-7860
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-7860
- OSV: https://osv.dev/vulnerability/CVE-2026-7860

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-7860/
Summaries are generated and may contain mistakes; the official description above is the record.
