# CVE-2026-78677: GitPython before 3.1.59 Path Traversal via separate-git-dir

> Attackers can exploit GitPython to create arbitrary directories outside the intended path, potentially enabling hook execution and code execution.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-78677, ECHO-ed72-7ed5-2b4c, GHSA-8mcc-hrx5-hvxc, MINI-prpc-vph8-v6pw, MINI-qxf7-hg33-vvhq, MINI-w7vm-8pwx-x6gg, MINI-xph7-5866-7gcp, PYSEC-2026-3787, ROOT-APP-PYPI-CVE-2026-78677

## What is CVE-2026-78677?

CVE-2026-78677 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitPython before 3.1.59 omits --separate-git-dir from unsafe_git_clone_options, allowing attackers to create arbitrary git directories outside the intended clone destination. Attackers can pass a separate_git_dir parameter to Repo.clone_from() or Repo.clone() to redirect repository metadata to an attacker-controlled filesystem path, enabling arbitrary directory creation and potential hook execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-78677?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.59 |
| `gitpython` | PyPI | All versions | 3.1.59 |
| `GitPython` | PyPI | All versions | 3.1.59 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-78677?

Upgrade gitpython to 3.1.59 or later.

## Is CVE-2026-78677 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78677 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78677 and fix it if it is affected.

What it is: CVE-2026-78677 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78677 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.59
- gitpython (PyPI): affected all versions; fixed in 3.1.59
- GitPython (PyPI): affected all versions; fixed in 3.1.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78677/ (Markdown: https://insights.sbomify.com/CVE-2026-78677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78677
- OSV: https://osv.dev/vulnerability/CVE-2026-78677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78677/
Summaries are generated and may contain mistakes; the official description above is the record.
