# CVE-2026-78679: GitPython before 3.1.59 Arbitrary File Read via TagReference.create

> Attackers can read arbitrary files by supplying crafted reference parameters to TagReference.create, exposing sensitive data to anyone using the library.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-78679, ECHO-e0f2-4441-3a92, GHSA-3wxw-xv34-2frg, MINI-cjw6-cfrf-4346, MINI-m28w-jx56-4772, MINI-mfwj-gf6g-mvch, MINI-xcq5-4f94-8g38, PYSEC-2026-3837

## What is CVE-2026-78679?

CVE-2026-78679 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitPython before 3.1.59 contains an arbitrary file read vulnerability in TagReference.create() where a positional reference parameter bypasses the unsafe option guard. Attackers can supply a reference value like --file=<path> to read arbitrary files, with contents returned in the annotated tag message.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-78679?

3 open source packages ship an affected version, including gitpython and GitPython.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.59 |
| `gitpython` | PyPI | All versions | 3.1.59 |
| `GitPython` | PyPI | All versions | 3.1.59 |

## How do I fix CVE-2026-78679?

Upgrade gitpython to 3.1.59 or later.

## Is CVE-2026-78679 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78679 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78679 and fix it if it is affected.

What it is: CVE-2026-78679 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 25 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78679 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.59
- gitpython (PyPI): affected all versions; fixed in 3.1.59
- GitPython (PyPI): affected all versions; fixed in 3.1.59

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78679/ (Markdown: https://insights.sbomify.com/CVE-2026-78679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78679
- OSV: https://osv.dev/vulnerability/CVE-2026-78679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78679/
Summaries are generated and may contain mistakes; the official description above is the record.
