# CVE-2026-78680: NLTK before 3.10.3 Arbitrary Code Execution via Graphviz dot Binary

> Attackers can execute arbitrary code by placing a malicious Graphviz binary in the search path, affecting NLTK users.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-78680, ECHO-54ff-3814-cf1f, GHSA-6hwm-xvph-95vm, MINI-2v44-pxwv-4639, PYSEC-2026-3868

## What is CVE-2026-78680?

CVE-2026-78680 is a high-severity command injection vulnerability in nltk, published on 25 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NLTK versions before 3.10.3 fail to use validated absolute paths when invoking the Graphviz dot binary in dependencygraph.dot2img and AlignedSent._repr_svg_, allowing attackers to execute arbitrary code by placing a malicious dot binary in the search path or current working directory. Attackers can exploit bare-name binary resolution on Windows via the current working directory or on Unix-like systems via relative PATH entries to execute their binary instead of the legitimate Graphviz tool.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-78680?

3 open source packages ship an affected version, including nltk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |
| `nltk` | PyPI | All versions | 3.10.3 |

## How do I fix CVE-2026-78680?

Upgrade nltk to 3.10.3 or later.

## Is CVE-2026-78680 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78680 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-78680 and fix it if it is affected.

What it is: CVE-2026-78680 is a high-severity command injection vulnerability in nltk, published on 25 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-78680 exists.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3
- nltk (PyPI): affected all versions; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-78680/ (Markdown: https://insights.sbomify.com/CVE-2026-78680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-78680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-78680
- OSV: https://osv.dev/vulnerability/CVE-2026-78680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-78680/
Summaries are generated and may contain mistakes; the official description above is the record.
